aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorTomasz Kramkowski <tomasz@kramkow.ski>2023-02-14 18:36:54 +0000
committerTomasz Kramkowski <tomasz@kramkow.ski>2023-02-14 18:36:54 +0000
commitac0b1401574711a26d494a80c03807e422cc0853 (patch)
tree19d1440d05c6448e8d5065c6aa4270747e418020 /pyproject.toml
parent0d143bb226e702006d6929c346b8d25a05e10b2e (diff)
downloadpaste-ac0b1401574711a26d494a80c03807e422cc0853.tar.gz
paste-ac0b1401574711a26d494a80c03807e422cc0853.tar.xz
paste-ac0b1401574711a26d494a80c03807e422cc0853.zip
First draft version
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..ffa45fe
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,19 @@
+[tool.poetry]
+name = "paste"
+version = "0.1.0"
+description = "A simple WSGI paste site"
+authors = ["Tomasz Kramkowski <tomasz@kramkow.ski>"]
+license = "MIT"
+readme = "README"
+
+[tool.poetry.dependencies]
+python = "^3.9"
+
+[tool.poetry.group.dev.dependencies]
+black = "^23.1.0"
+vermin = "^1.5.1"
+pyright = "^1.1.0"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"