summaryrefslogtreecommitdiffstats
path: root/openat/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'openat/Cargo.toml')
-rw-r--r--openat/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/openat/Cargo.toml b/openat/Cargo.toml
new file mode 100644
index 0000000..a5b5b3f
--- /dev/null
+++ b/openat/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "openat"
+description = """
+ A wrapper around openat, symlinkat, and similar system calls
+"""
+license = "MIT/Apache-2.0"
+readme = "README.md"
+keywords = ["open", "openat", "filesystem", "fs"]
+categories = ["filesystem", "api-bindings"]
+repository = "https://github.com/tailhook/openat"
+homepage = "https://github.com/tailhook/openat"
+documentation = "http://docs.rs/openat"
+version = "0.1.21"
+authors = ["paul@colomiets.name"]
+edition = "2018"
+
+[dependencies]
+libc = "0.2.34"
+
+[dev-dependencies]
+argparse = "0.2.1"
+tempfile = "3.0.3"