aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..a078486
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,15 @@
+[project]
+name = "brightness"
+version = "1.0.0"
+description = "A basic log-scale sysfs brightness adjuster"
+readme = "README.md"
+requires-python = ">=3.4"
+license = { file = "LICENSE" }
+authors = [{ name = "Tomasz Kramkowski", email = "tomasz@kramkow.ski" }]
+
+[project.scripts]
+brightness = "brightness:main"
+
+[build-system]
+requires = ["whey"]
+build-backend = "whey"