diff options
author | Tomasz Kramkowski <tomasz@kramkow.ski> | 2024-12-08 12:01:31 +0000 |
---|---|---|
committer | Tomasz Kramkowski <tomasz@kramkow.ski> | 2024-12-08 12:01:31 +0000 |
commit | cd403a91e6078956445aeb21d6509e863b0592ae (patch) | |
tree | b1bb59ed526081be31494544f8920c39f0588711 /Cargo.toml | |
parent | 0edd5527161809dfbc0c76e39c462e3a4f00beb7 (diff) | |
download | ads1x1x-async-async.tar.gz ads1x1x-async-async.tar.xz ads1x1x-async-async.zip |
Modify to use asyncasync
A changeover from embedded_hal::i2c::I2c to embedded_hal_async::i2c::I2c
including changes to all the relevant functions into async functions.
Tests have been updated to work using futures-test and embedded-hal-mock
with the embedded-hal-async feature.
Examples have been kept the same meaning they no longer compile.
Currently it doesn't _seem_ like the linux embedded hal can do async
i2c so maybe these should be re-written to use embassy?
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -22,10 +22,11 @@ edition = "2021" [dependencies] nb = "1" -embedded-hal = "1" +embedded-hal-async = "1.0.0" [dev-dependencies] -embedded-hal-mock = { version = "0.10", default-features = false, features = ["eh1"] } +embedded-hal-mock = { version = "0.11.1", default-features = false, features = ["eh1", "embedded-hal-async"] } +futures-test = "0.3.31" [target.'cfg(target_os = "linux")'.dev-dependencies] linux-embedded-hal = "0.4" |