summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorcs2dsb <cs2dsb@gmail.com>2020-01-08 22:25:31 +0000
committercs2dsb <cs2dsb@gmail.com>2020-01-08 22:25:31 +0000
commitc0c2b922b272f2b87b1a907e49499260a430ce23 (patch)
treefd71d9d120034c2d2d32e4d49afa82f9a21d2ca6 /Cargo.toml
downloadmax31855-async-c0c2b922b272f2b87b1a907e49499260a430ce23.tar.gz
max31855-async-c0c2b922b272f2b87b1a907e49499260a430ce23.tar.xz
max31855-async-c0c2b922b272f2b87b1a907e49499260a430ce23.zip
Initial commit, cargo version 0.1
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..7871ca3
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "max31855"
+version = "0.1.0"
+authors = ["cs2dsb <cs2dsb@gmail.com>"]
+edition = "2018"
+description = "Driver for MAX31855 SPI thermocouple converter"
+categories = ["hardware-support"]
+keywords = ["embedded-hal-driver", "max31855", "no_std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/cs2dsb/max31855.rs"
+readme = "README.md"
+documentation = "https://docs.rs/max31855"
+homepage = "https://github.com/cs2dsb/max31855.rs"
+
+[dependencies]
+embedded-hal = { version = "0.2.3" }
+bit_field = "0.10.0" \ No newline at end of file