summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6cadb28..c1ad453 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -22,10 +22,11 @@ edition = "2021"
[dependencies]
nb = "1"
-embedded-hal = "1"
+embedded-hal-async = "1.0.0"
[dev-dependencies]
-embedded-hal-mock = { version = "0.10", default-features = false, features = ["eh1"] }
+embedded-hal-mock = { version = "0.11.1", default-features = false, features = ["eh1", "embedded-hal-async"] }
+futures-test = "0.3.31"
[target.'cfg(target_os = "linux")'.dev-dependencies]
linux-embedded-hal = "0.4"