summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDiego Barrios Romero <eldruin@gmail.com>2018-11-04 21:32:46 +0100
committerDiego Barrios Romero <eldruin@gmail.com>2018-11-04 21:32:46 +0100
commit5a5d08f92768c48949cb175605055b853e559c5c (patch)
treedb71b7805fbb47acc57c09f7a659f9dc205ed47d /Cargo.toml
downloadads1x1x-async-5a5d08f92768c48949cb175605055b853e559c5c.tar.gz
ads1x1x-async-5a5d08f92768c48949cb175605055b853e559c5c.tar.xz
ads1x1x-async-5a5d08f92768c48949cb175605055b853e559c5c.zip
Initial version
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..3e48b88
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,34 @@
+[package]
+name = "ads1x1x"
+version = "0.1.0"
+authors = ["Diego Barrios Romero <eldruin@gmail.com>"]
+repository = "https://github.com/eldruin/ads1x1x-rs"
+license = "MIT OR Apache-2.0"
+description = "Platform-agnostic Rust driver for the ADS1013, ADS1014, ADS1015, ADS1113, ADS1114, ADS1115, ADS1018 and ADS1118 ultra-small, low-power analog-to-digital converters (ADC)."
+readme = "README.md"
+keywords = ["adc", "analog", "driver", "embedded-hal-driver"]
+categories = ["embedded", "hardware-support", "no-std"]
+homepage = "https://github.com/eldruin/ads1x1x-rs"
+documentation = "https://docs.rs/ads1x1x"
+include = [
+ "**/*.rs",
+ "Cargo.toml",
+ "README.md",
+ "CHANGELOG.md",
+ "LICENSE-MIT",
+ "LICENSE-APACHE",
+]
+
+[badges.travis-ci]
+branch = "master"
+repository = "eldruin/ads1x1x-rs"
+
+[dependencies]
+embedded-hal = "0.2.2"
+
+[dev-dependencies]
+linux-embedded-hal = "0.2"
+embedded-hal-mock = "0.4"
+
+[profile.release]
+lto = true